File: composer.json

Recommend this page to a friend!
  Classes of Sascha Greuel  >  PHP JSON Path  >  composer.json  >  Download  
File: composer.json
Role: Auxiliary data
Content type: text/plain
Description: Auxiliary data
Class: PHP JSON Path
Query values from data structures like XPATH
Author: By
Last change: 0.7.5
0.7.4

Removed PHPUnit from conflicting packages
remove phpunit from conflicting packages

`conflict` is used to mention conflicting production packages, not dev packages.
From what I can tell, you are not exposing a production feature related to PHPUnit.

Keeping it like it is right now doesn't allow installing your package in another system where dev requiements would have lower than 7 version of phpunit and I think it's an artificial conflict that should not exist.
0.7.3
Date: 3 months ago
Size: 1,332 bytes
 

Contents

Class file image Download
{
  "name": "softcreatr/jsonpath",
  "description": "JSONPath implementation for parsing, searching and flattening arrays",
  "version": "0.7.5",
  "license": "MIT",
  "authors": [
    {
      "name": "Stephen Frank",
      "email": "stephen@flowsa.com",
      "homepage": "https://prismaticbytes.com",
      "role": "Developer"
    },
    {
      "name": "Sascha Greuel",
      "email": "hello@1-2.dev",
      "homepage": "http://1-2.dev",
      "role": "Developer"
    }
  ],
  "require": {
    "php": ">=7.1",
    "ext-json": "*"
  },
  "replace": {
    "flow/jsonpath": "*"
  },
  "require-dev": {
    "phpunit/phpunit": ">=7.0",
    "roave/security-advisories": "dev-master",
    "squizlabs/php_codesniffer": "^3.5"
  },
  "config": {
    "optimize-autoloader": true,
    "preferred-install": "dist"
  },
  "autoload": {
    "psr-4": {
      "Flow\\JSONPath\\": "src/"
    }
  },
  "autoload-dev": {
    "psr-4": {
      "Flow\\JSONPath\\Test\\": "tests/"
    }
  },
  "minimum-stability": "stable",
  "scripts": {
    "cs-check": "phpcs",
    "cs-fix": "phpcbf",
    "test": "phpunit"
  },
  "support": {
    "email": "hello@1-2.dev",
    "forum": "https://github.com/SoftCreatR/JSONPath/discussions",
    "issues": "https://github.com/SoftCreatR/JSONPath/issues",
    "source": "https://github.com/SoftCreatR/JSONPath"
  }
}
For more information send a message to info at phpclasses dot org.